Author Topic: 10 Hp Briggs Problems  (Read 11571 times)

0 Members and 1 Guest are viewing this topic.

Offline 08racernoob

  • Newbie
  • *
  • Posts: 81
  • Karma: 0
  • wanna play ball?
    • View Profile
10 Hp Briggs Problems
« on: August 09, 2008, 10:28:38 am »
 I was riding it when it fell on its face and died and the points don't spark
and we just put a new condencer on it what could it be?

Offline joshco84

  • Turf Warrior
  • **
  • Posts: 109
  • Karma: 1
    • View Profile
Re: 10 Hp Briggs Problems
« Reply #1 on: August 09, 2008, 10:39:52 am »
well if the points wont spark it could be the points need replaced. But it could aslo be coil or condensor as well.

Offline 08racernoob

  • Newbie
  • *
  • Posts: 81
  • Karma: 0
  • wanna play ball?
    • View Profile
Re: 10 Hp Briggs Problems
« Reply #2 on: August 09, 2008, 12:01:19 pm »
hope it ain't the coil
what is inside the block to make the points work?

Offline briggsracer1892

  • Turf Warrior
  • **
  • Posts: 316
  • Karma: 0
  • Gender: Male
  • wheeee
    • View Profile
Re: 10 Hp Briggs Problems
« Reply #3 on: August 09, 2008, 12:03:37 pm »
points and condesor are under flywheel. usually you can upgrade to the magnetron ignition because points are a pain in the @$$
sit down, hold on, shut up

Offline cycloneracer

  • Easy Parcheesy!!!!!!!
  • Global Moderator
  • Highly Mowtivated
  • *****
  • Posts: 4117
  • Karma: 37
  • Gender: Male
  • Easy Parcheesy!!!!!!!
    • View Profile
Re: 10 Hp Briggs Problems
« Reply #4 on: August 09, 2008, 12:11:21 pm »
I'd say upgrade.  But make sure to buy a Briggs coil.  I have found that the aftermarket ones (NAPA) are junk.  The Napa ones really don't like the ARC flywheel!

Paul

Paul Krueger

****2017 USLMRA FXT points Champion****

#150 Worlds First "sidewinder" FX (now dismantled)

#150 FXT  Sponsored by Zach Kerber Machine. http://zkbrmachine.com/

Easy Parcheesy Racing

Offline 08racernoob

  • Newbie
  • *
  • Posts: 81
  • Karma: 0
  • wanna play ball?
    • View Profile
Re: 10 Hp Briggs Problems
« Reply #5 on: August 09, 2008, 12:26:00 pm »
thisone has points and condenser on the block cause it is a horozontal shaft it is model
243431

Offline AcreFarm04

  • Turf Warrior
  • **
  • Posts: 103
  • Karma: 0
  • Gender: Male
    • View Profile
Re: 10 Hp Briggs Problems
« Reply #6 on: August 09, 2008, 12:53:36 pm »
Have you cleaned re-gapped the points?   If not give that a shot.   Gap to .020"  If they are oily when you pull the cover off you will need to replace or add a plunger seal.   Some older models didn't come with a seal.
If that doesn't work get a new set of points, new condenser and a new plug.   If after you do those things you continue to have an issue of it running till it warms up, then losing spark it's time to buy a coil.

Offline 08racernoob

  • Newbie
  • *
  • Posts: 81
  • Karma: 0
  • wanna play ball?
    • View Profile
Re: 10 Hp Briggs Problems
« Reply #7 on: August 09, 2008, 01:53:11 pm »
my uncle regapped the points and got a new condenser before we even started it
would the coil off of a 5,8 or 12 hp engine fit?
got spares of those around

Offline Squidd

  • Global Moderator
  • Highly Mowtivated
  • *****
  • Posts: 6906
  • Karma: 92
  • Gender: Male
    • View Profile
Re: 10 Hp Briggs Problems
« Reply #8 on: August 09, 2008, 01:55:10 pm »
If you have a newer model magnatron coil (no points wire coming to it only kill wire coming off) you could put that on and skip the whole points/condenser thing...
Randy Stys
"Pull My Finger"
 63 Cub Cadet S/A

Offline 08racernoob

  • Newbie
  • *
  • Posts: 81
  • Karma: 0
  • wanna play ball?
    • View Profile
Re: 10 Hp Briggs Problems
« Reply #9 on: August 09, 2008, 02:48:20 pm »
yeah i got 2 of those and one electronic coil
so one of those other coils should work?

Offline AcreFarm04

  • Turf Warrior
  • **
  • Posts: 103
  • Karma: 0
  • Gender: Male
    • View Profile
Re: 10 Hp Briggs Problems
« Reply #10 on: August 09, 2008, 03:13:14 pm »
From the IPL it looks like your 12hp coil should work, can't say for sure tho.  Pull the shroud off and take a look at it.   If it doesn't, Briggs sells Magnetron kits that eliminate the use points on your engine
part # 394970

Offline 08racernoob

  • Newbie
  • *
  • Posts: 81
  • Karma: 0
  • wanna play ball?
    • View Profile
Re: 10 Hp Briggs Problems
« Reply #11 on: August 09, 2008, 10:21:13 pm »
it fits but i didn't get any spark still

Offline Rooster

  • Global Pot Stirrer
  • Highly Mowtivated
  • ****
  • Posts: 8255
  • Karma: 73
  • Gender: Male
  • Winning is always fair!!
    • View Profile
    • Cut Loose Racing
Re: 10 Hp Briggs Problems
« Reply #12 on: August 09, 2008, 10:49:23 pm »
Make sure nothings rusty. If you have no spark, it's either installed wrong or it's bad.
Bert stole my cookies!!
 I think he used them to bribe Ed into something naughty?

http://www.cutlooseracing.com

Offline mightymowe

  • Turf Warrior
  • **
  • Posts: 752
  • Karma: 0
  • Gender: Male
    • View Profile
Re: 10 Hp Briggs Problems
« Reply #13 on: August 09, 2008, 11:29:55 pm »
Or the plug is bad.
David Peters

Offline joshco84

  • Turf Warrior
  • **
  • Posts: 109
  • Karma: 1
    • View Profile
Re: 10 Hp Briggs Problems
« Reply #14 on: August 09, 2008, 11:33:03 pm »
or the wire is no good as well

 

anything